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TradeStationTM Interface via email notification 
The AutoX plugin supports capturing four types of strategy notifications, order type mapping (buy to 
cover to buy or sell short to sell), manual order confirmation, symbol mapping, advanced account 
assignment, and redirection of email notifications to user’s email client. In order for signals to be 
captured from TradeStationTM, the local SMTP port cannot be used by another process. Moreover, only 
one OEC Trader can capture signals per computer. 
 

Installation Instructions: 
AutoX may be found on our website at: http://www.gainfutures.com/education-center/downloads.cfm.   
Please make sure OEC Trader is closed when installing the plugin.  Download the file from link provided 
and run the installer and follow the screen prompts. 

TradeStationTM and OEC Trader Settings 

System requirements 

 If using AutoX on a server, please be sure that Windows SMTP service is disabled.  To check, 
open the Windows Control Panel and go to the Administrative Tools, then go to Services area.  
Disable the Windows SMTP service, if it is installed and started: use a right click to open 
“Properties.”  Change “Startup type” to “Disabled” and press “Stop,” then OK. 

 If you use a SMTP service, please stop this service or re‐configure it to not use port 25.  Be sure 
to close all other TradeStationTM capture applications which use port 25. 

 Check your firewall settings and make sure the SMTP port is not blocked for local use. 

 Only one instance of OEC Trader can capture TradeStationTM signals (eg. Demo or Live but not 
both platforms running AutoX at once). 

 

OEC Trader 

1. From the menu bar of OEC Trader, go to File > Plugins > AutoX  > Capture Settings: 
2. Fill out the “From:” field in the Email settings section with the same email address used in 

TradeStationTM Messaging, eg. autox@noreply.com. 
3. Check “Outgoing SMTP” box, if you want to redirect the TradeStationTM messages to your email 

client.  This is not necessary unless you require notification be redirected to your email. 
4. Check “Enabled” and adjust “Manual Confirmation” setting, if necessary. 
5. Set the appropriate mapping settings, explained in the next section of user guide on page 8. 
 

http://www.gainfutures.com/education-center/downloads.cfm
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Options Explained: 

Feature Description 

Enabled Start capturing TradeStationTM signals 

Manual Confirmation Asks for user a confirmation on all TradeStationTM reports. 
User can review corresponding order and send, modify or 
cancel, decline report and corresponding action, or allow it 
to execute corresponding action immediately 

Send market order on Filled report A market order will be sent, when a TradeStationTM 
Strategy order is filled. All other types from TradeStationTM 
reports are ignored and skipped. If the order is cancelled, 
no actions are performed at all. This option ensures 
the most accurate synchronization of positions (during this 
process, if positions are synchronized initially) 

Send signals AS‐IS OEC Trader sends an order that is identical to the 
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Feature Description 

TradeStationTM Strategy order description, with exception 
to short order type (“sell short” is treated as “sell”, “buy to 
cover” is treated as “buy”).   Because TradeStationTM order 
types and OEC Trader order types are filled in different 
environments, the TradeStationTM Strategy and OEC Trader 
positions could become unsynchronized. 

Send AS‐IS, but convert to market on 

Filled report 

The same as previous option, but a conditional order will be 
modified to a market order on a Filled report from 
TradeStationTM, if an OEC order is not filled in selected 
timeout. 
 
Modify to Market handled as limit.  Since our order 
gateway does not support modify requests to a Market 
order, this command would get rejected.  As a workaround, 
this option will adjust the limit price to simulate a market 
order. 

Desynchronization Timeout Displays an alert, if the OEC order has been filled, but the 
TradeStationTM Strategy order is still working (no incoming 
Filled report for this order). 

 

Note:  To decrease desynchronization of positions, a market order will be sent on a Filled report from 
TradeStationTM when the option “Send signals AS‐IS” is selected.  If the original order is rejected and the 
reason is related to trigger price, the rejection message will state “trigger price.” 

 

 

TradeStationTM 

1. Open the TraderManager window in TradeStationTM.  Go to File > New Window > Trade 

Manager or use the navigational pane on the right side. 

2. Open the Trader Manager Preferences via View in main menu of TradeStationTM. 
3. Set email notification for Strategy Active, Canceled, Filled and Replaced Order 
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4. Check “Enable e‐mail notification” and press “Configure...” 
 

 
 

5. In the message dialog box enter “autox@noreply.com” for the “From” and “to” email address 
fields, and “LOCALHOST” or “127.0.01” in “SMTP Server name” field, see image on next page.   
 

(For TradeStationTM versions before 9.1 Update 12, enter settings like below) 
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(For TradeStationTM version 9.1 Update 12 or later, enter settings like below) 

 

Press OK and a prompt will appear to send a test message.  You will see dialog two windows: one from 
TradeStation and one from OEC Trader.  The message will confirm if the test has been sent and received.  
If the message is not received, please check Firewall and Anti-virus settings.  
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Go back into OEC Trader and go to File > Plugins > AutoX > Capture Settings to configure additional 
settings.   
 

Messages and Notifications (optional) 
It is possible to redirect all incoming messages to a 3rd party SMTP‐enabled software or email accounts. 
Please check with your email provider for the host or server name, port, and if authentication is 
required.   AutoX can send the connection status and internal error notifications to the selected email 
addresses.  Additionally, it is possible to send SMS messages to cellular or mobile phones.   The user can 
simply type their cell phone number in the “Send error and connection notifications to:” field.  Use the 
following guide for assistance of what email address to use: 
 
 

If your carrier is not listed, please check:  
http://en.wikipedia.org/wiki/List_of_SMS_gateways 
 

 
 
 
 
 
 
 
 
 
  

Carrier Address 

AT&T 10digitphonenumber@txt.att.net 

Boost Mobile 10digitphonenumber@myboostmobile.com 

CenturyLink (formerly 
CenturyTel and Qwest) 

Many exist, check  
http://qwest.centurylink.com/internethelp/email-
server-settings.html  

Metro PCS 10digitphonenumber@mymetropcs.com 

Nextel 10digitphonenumber@messaging.nextel.com 

Sprint 10digitphonenumber@messaging.sprintpcs.com 

T-Mobile 10digitphonenumber@tmomail.net 

Tracfone 10digitphonenumber@txt.att.net 

US Cellular 10digitphonenumber@email.uscc.net  

Verizon 10digitphonenumber@vtext.com 

Virgin Mobile 10digitphonenumber@vmobl.com 

http://en.wikipedia.org/wiki/List_of_SMS_gateways
http://qwest.centurylink.com/internethelp/email-server-settings.html
http://qwest.centurylink.com/internethelp/email-server-settings.html
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Message and Notification Limitations  
 
The AutoX plugin currently only supports regular, non-secured SMTP connections. Secured connections 
like TLS (Transport Layer Security) and STARTTLS (as required by Gmail, for example) are not supported.  
If the mail server requires a SSL connection, you will get the following error:  
 

 
 

Mapping (required) 
There are two modes of mapping: Simple and Extended.  Simple mapping has two parts: one maps the 
workspace name to account and the other maps the symbols.  Each TradeStationTM  workspace is 
mapped separately.  The default symbol map is used for extended mapping only. 
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Simple Mapping 

Account Selection  

This window maps the workspace name of the incoming signal(s) to an account number.  The signals 
from non‐defined workspaces are ignored.  Each workspace can only be assigned to one account or one 
allocation block name. 
 

 

Symbol Mapping: 

This window allows the mapping of the AutoX (TradeStationTM) symbol to the OEC Trader symbol.  
Specifically, it maps corresponding TradeStationTM continuous symbols to specific OEC Trader symbols.  
In the event of quotation differences, you may also adjust the sent price by using a Price Multiplier to 
reflect the price quoted by OEC Trader.  Each workspace has its own symbol mapping.  If the symbol is 
not defined in the mapping, its signals will be ignored.  
 

Price multiplier used 

 

 
Non-continuous mapping 
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Continuous mapping 

 
          

Extended Mapping 
This mode uses the incoming workspace name, AutoX symbol, and the interval to map to the OEC Trader 
account and contract.  To get started, click on the Extended tab and then click on Add. 
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There are several areas within extended mapping that can be configured. 

 

Workspace 

 
Pick the Workspace file used in 
TradeStationTM.  They are usually 
located in MyWork folder (eg. 
C:\Program Files\TradeStation 
9.1\MyWork). 
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AutoX to OEC Symbol Mapping 

 
Enter the symbol used in the TradeStationTM platform as the AutoX symbol, eg. ESM12 and to the 
immediate right the OEC symbol, eg. ESM2.   

 If you wish to map the AutoX symbol to the base OEC symbol, select the radio box next to Symbol:.  
Please be aware that this will map the AutoX symbol to the first month offered in the OEC data feed.  
This may not necessarily be the active month traded.   

 If using the continuous symbol, it is usually mapped as ES and not @ES, even though your chart may 
display this formatting of symbol.  The reason for this is the TradeStationTM email notification sends 
us ES instead of @ES.  Be sure to use AutoX log window to see if adjustments will be necessary. 

 If you wish to use the default symbol map, from prior screen, select Any (default symbol map). 
 

 

Quantity Multiplier (typically used for Allocation Block Trading) 

 
This field allows you to increase the number of lots traded without having to adjust in TradeStationTM.  
This is typically used for Allocation Blocks.  When trading into an Allocation Block, you should match the 
Total Lots with Qty Multiplier and designate in account drop down the Allocation Block name.  If you 
make changes to the block, you must change the AutoX setting as well. 
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Interval: 

 
This field is used to map the extended AutoX mapping to a specific minute interval used in the 
TradeStationTM chart.  This could be helpful if you use the same workspace file with same symbol 
mapping but have a different strategy for a different interval.  Most users will keep this setting as Any. 
 

 

Check Duplicate Signals 

 

 

Signals/Order Type Mapping 

 
This section allows mapping order types that are not recognized by OEC but are in TradeStationTM.  An 
example of this would Buy to Cover or Sell Short.   
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To add a new order type mapping for all or particular signal names, click on Add.  To view current 
mappings, click on Mappings. 
 

 

When you add a new order type mapping, a new entry will appear.  Pick the signal name from the drop 

down list and select New… under Order Type Mapping in the drop down list. 

 

Name the order type mapping and choose how OEC Trader should send the order for execution.  (Eg.  

Send Buy-to-Cover Limit as Buy Limit). 
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Below is an example mapping BUY and SELL signal using the custom OEC mapping and the EXIT signal 

using the Standard mapping. 
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Process 
1. Insert the 

EasyLanguage 
strategy in the 
“Chart Analysis” 
window in 
TradeStationTM. 
To enable the 
Strategy in 
TradeStationTM, 
right click in chart 
and go to Format 
Strategies.  Then, 
activate 
Generate 
strategy orders… 

 
 
 

 
 

2. Login to OEC Trader and ensure AutoX is enabled.  Go to File > Plugins > AutoX > Capture 
Activated (checked)  

 
(disconnected) 

 

(connected) 
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3. Catch and confirm (if “Manual Confirmation” is checked) the signals from TradeStationTM in OEC 
Trader.  The signal name and interval of the base chart is located in comments of the OEC Trader 
order. 

 

 
 

Log 
A log of TradeStationTM interaction is stored to file and can be viewed inside the OEC Trader using the 
AutoX Log window.  To view this window go to:  File  > Plugins > AutoX > Log 
 
 

 

Queued Messages 
All TradeStationTM messages are queued in the case of a disconnection to OEC Servers and pushed to 
execution after a successful reconnection. In addition, OEC Trader pre‐processes the queued messages 
with following rules: 
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1. If queue contains Active message and corresponding Cancel is incoming, no order will be sent 
on reconnection. 

2. If queue contains Active message and corresponding Replace is incoming, modified version of 
order will be issued instead of original one 

3. If queue contains Active or Replace message and corresponding Filled is incoming, market order 
will be issued. 

4. If queue contains two Active messages with equal quantity, workspace, interval, symbol and 
both marked as “Send as MKT”, these orders will be removed from queue (“closed in order 
received”)  

 
To view the current queued messages, go to File > Plugins > AutoX > Queued Orders. 
 

 

TradeStationTM Email format: 

Example of a new order email notification: 
 

TradeStation - Strategy Active Order for NQM07 

 

Order: Buy 1 NQM07 @ 1834.00 Stop Market 

Account: 

Occurred: 4/13/2007 4:24:06 PM 

Signal: NewHi 

Interval: 1 min. 

Workspace: C:\Program Files\TradeStation 8.2 (Build 3894)\MyWork\OECTEST 

Example of a cancel request notification: 
 

TradeStation - Strategy Canceled Order for NQM07 

 

Order: Buy to Cover 1 NQM07 @ 1834.00 Stop Market 

Account: 

Occurred: 4/13/2007 4:27:06 PM 

Signal: NewHi 

Interval: 1 min. 

Workspace: C:\Program Files\TradeStation 8.2 (Build 3894)\MyWork\OECTEST 
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Optional Reading 

OEC API functionality inside EasyLanguage 

General 

Implemented in OEC Trader is a TradeStationTM extension that provides the full functionality of OEC API 
inside TradeStationTM strategy scripts. The extension has 457 functions that reflect all objects, properties 
and methods of OEC API. OEC API code is called from the extension indirectly. Actually the OEC API is 
hosted by OEC Trader and exposes OEC API functionality to TradeStationTM. The extension allows a 
strategy to avoid the limitations of TradeStationTM. The TradeStationTM strategy will have access to OEC 
Trader average positions, account balances, basic and advanced orders, handle failure situations, avoid 
synchronization troubles, and etc. In other words, TradeStationTM + extension provide one more 
programming environment that can be used by TradeStationTM‐related programmers instead of .Net 
environment. This extension can be used independently of the email notification capture feature (send 
orders through extension instead of TradeStationTM constructions) as well as together. A strategy could 
get extension functions to obtain positions and balances, but use TradeStationTM construction to send 
orders. 

Infrastructure 

The scheme below shows the process boundary, inter‐process communication via .NET remoting, and 
data flow. 

 
 

So by this scheme, OEC Trader shows all order manipulations real‐time from the TradeStation’s strategy 
and vice versa. The strategy can take into account user operations, real OEC Trader positions and prices. 

Installation and Settings 

Open AutoX Capture Settings dialog to find “Install TS Extension” and “Extension Enabled” at the bottom 
left of the window. 
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Installation 

TradeStationTM Extension consists from of files (OecFuncs.dll and TSGateway.dll) and is installed to OEC 
Trader folder at the time of the OEC Trader installation. At this time these files are placed on the users 
computer, but not integrated into TradeStationTM. A user can install and integrate this extension to 
TradeStationTM environment via the “Install TS Extension” button. The required files will be copied to 
TradeStationTM folder. Now “Extension” and “Remoting consumer” components from scheme above are 
installed and a user can export OEC functions from the extension and verify strategies. 

Enabling 

In spite of the components installed, the link between “Remoting provider” and “Remoting consumer” is 
not established yet (see scheme above). “Extension enabled” option responds only when the Extensions 
Enabled checkbox is selected. 

Error Processing 

The TradeStation extension supports native TradeStation events and error processing mechanisms that 
protects TradeStation from crashing. All exceptions are captured and shown in TradeStation Event 
Manager. 

OEC Extension Functions 

All functions have the same pattern and use OEC API name convention. 
 

1. Selection of objects for further operations  
 
oecSelectXXX(name of object); 
oecSelectXXXByID(id of object); 
oecSelectXXXByIndex(index in collection) 
where XXX is OEC API object. 

Sample: 

* oecSelectAccount(“TEST001”)   →  select and use TEST001 in further operations 
* oecSelectContractGroupByIndex(0)  →  select and use first contract group from collection of 

groups 
 

2. Access to OEC API data and methods 
 

After object selection, strategy can read its data and call its methods. The pattern of getter functions 
and methods is: 
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oecXXXYYYZZZ(parameters) 
where XXX – name of OEC API object (optionally); 
YYY – name of nested OEC API object (optionally) 
ZZZ – name of OEC API method or property. 

 

Sample: 

* oecIsCompleteConnected()   →  OEC.API.OECClient.Global. CompleteConnected 
* oecAccountName()  →  OEC.API.Account.Name. Account should be selected 

before by means of any oecSelectAccount***() 
function. 

Example of strategy 

This example code shows the use of different functions from different areas of the OEC Trader 
TradeStationTM Extension (contract listing, average positions, sending orders ((simple, OCO, brackets)), 
allocation block construction/usage, canceling and modifying). 
 
{ Import external OEC API functions } 

External: "OecFuncs.dll", bool, "oecIsCompleteConnected"; 

External: "OecFuncs.dll", int, "oecAvgPositionNetVolume"; 

External: "OecFuncs.dll", double, "oecAvgPositionNetPrice"; 

External: "OecFuncs.dll", bool, "oecSelectAccountByIndex", int{{AccountIndex}}; 

External: "OecFuncs.dll", bool, "oecSelectContract", LPSTR{{symbol}}; 

External: "OecFuncs.dll", LPSTR, "oecAvgPositionContract"; 

External: "OecFuncs.dll", double, "oecAvgPositionGain"; 

External: "OecFuncs.dll", LPSTR, "oecAccount"; 

External: "OecFuncs.dll", void, "oecFreeze"; 

External: "OecFuncs.dll", void, "oecUnfreeze"; 

External: "OecFuncs.dll", bool, "oecSelectContractByIndex", int{{ContractIndex}}; 

External: "OecFuncs.dll", int, "oecContractsCount"; 

External: "OecFuncs.dll", LPSTR, "oecContractPositionSymbol"; 

External: "OecFuncs.dll", LPSTR, "oecContractName"; 

External: "OecFuncs.dll", LPSTR, "oecContract"; 

External: "OecFuncs.dll", LPSTR, "oecCreateDraft", LPSTR{{Side}}, int{{Qty}}, LPSTR{{Type}}, 

double{{Price}}, double{{Price2}}, LPSTR{{Flags}}, LPSTR{{Comments}}; 

External: "OecFuncs.dll", LPSTR, "oecSetDraftTime", LPSTR{{Draft}}, double{{Start}}, 

double{{End}}; 

External: "OecFuncs.dll", LPSTR, "oecCheckDraft", LPSTR{{Draft}}; 

External: "OecFuncs.dll", bool, "oecSendOrder", LPSTR{{Draft}}; 

External: "OecFuncs.dll", LPSTR, "oecSetDraftIceberg", LPSTR{{Draft}}, int{{Volume}}; 

External: "OecFuncs.dll", double, "oecCurrentPriceLastPrice"; 

External: "OecFuncs.dll", int, "oecOrdersCount"; 

External: "OecFuncs.dll", bool, "oecIsOrderIsFinalState"; 

External: "OecFuncs.dll", bool, "oecCancelOrder"; 

External: "OecFuncs.dll", int, "oecOrder"; 

External: "OecFuncs.dll", bool, "oecSelectOrderByIndex", int{{OrderIndex}}; 

External: "OecFuncs.dll", bool, "oecSendOCO", LPSTR{{Draft1}}, LPSTR{{Draft2}}; 

External: "OecFuncs.dll", bool, "oecSendLinked2", LPSTR{{MainDraft}}, LPSTR{{LinkedDraft1}}, 

LPSTR{{LinkedDraft2}}; 

External: "OecFuncs.dll", bool, "oecSelectAvgPositionByIndex", int{{AvgPositionIndex}}; 

External: "OecFuncs.dll", int, "oecAvgPositionsCount"; 

External: "OecFuncs.dll", LPSTR, "oecAvgPositionPositionContract"; 

External: "OecFuncs.dll", double, "oecTotalBalanceNetLiquidatingValue"; 

External: "OecFuncs.dll", LPSTR, "oecContractType"; 

External: "OecFuncs.dll", void, "oecInitializeAllocationBlock", LPSTR{Name}, LPSTR{Rule}, 

LPSTR{AccountLotsList}; 

External: "OecFuncs.dll", int, "oecAccountsCount"; 

External: "OecFuncs.dll", LPSTR, "oecAccountCH"; 
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External: "OecFuncs.dll", LPSTR, "oecAccountType"; 

External: "OecFuncs.dll", LPSTR, "oecAccountTrader"; 

External: "OecFuncs.dll", bool, "oecModify", int{Quantity}, LPSTR{Type}, double{Price}, 

double{Price2}; 

External: "OecFuncs.dll", int, "oecOrderQuantity"; 

External: "OecFuncs.dll", LPSTR, "oecOrderType"; 

External: "OecFuncs.dll", int, "OnCreateProc", IEasyLanguageObject; 

External: "OecFuncs.dll", int, "OnDestroyProc", IEasyLanguageObject; 

#Events 

OnCreate = OnCreateProc; 

OnDestroy = OnDestroyProc; 

#End; 

 

 

variables: counter(0), qty(0), price(0.0), draft(""), draft2(""), draft3(""), AB(""), ABSize(0); 

if LastBarOnChart then 

begin 

{ Freeze OEC Trader and OEC API data during strategy body calculations } 

oecFreeze(); 

 

{ Check connection status of OEC Trader } 

if oecIsCompleteConnected() then 

begin 

AB = ""; 

ABSize = 0; 

qty = 0; 

 

{ Select and use ESM7 hereinafter } 

oecSelectContract("ESM7"); 

for counter = 0 to oecAccountsCount() - 1 

begin 

oecSelectAccountByIndex(counter); 

Print(oecAccount(), ", ", oecAccountCH(), ", ", oecAccountType(), ", ", 

oecAccountTrader()); 

if oecAccountCH() = "RJO" and oecAccountType() = "Customer" and 

oecAccountTrader() = "vic" then begin 

if AB <> "" then 

AB = AB + ","; 

AB = AB + oecAccount() + "=1"; 

ABSize = ABSize + 1; 

qty = qty + oecAvgPositionNetVolume(); 

end; 

end; 

 

Print("AB: ", AB, ", Size: ", ABSize, "; sum pos: ", qty); 

if qty < 0 then 

ABSize = - ABSize; 

 

{ Use first account } 

oecSelectAccountByIndex(0); 

 

{ list and prints all available contracts } 

For counter = 0 To oecContractsCount()-1 Begin 

oecSelectContractByIndex(counter); 

Print(oecContract(), ": ", oecContractName(), " ", oecContractType()); 

end; 

 

for counter = 0 to oecAvgPositionsCount()-1 

begin 

oecSelectAvgPositionByIndex(counter); 

Print("Position: ", oecAvgPositionPositionContract(), 

"; Volume:", oecAvgPositionNetVolume():10, 

"; Avg.Price:", oecAvgPositionNetPrice():10, 

"; Gain: ", oecAvgPositionGain()); 

end; 
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Print("Net Liq. Value: ", oecTotalBalanceNetLiquidatingValue():10:2); 

 

{ Select and use ESM7 hereinafter } 

oecSelectContract("ESM7"); 

 

{ Print ESM7 average position } 

qty = oecAvgPositionNetVolume(); 

price = oecAvgPositionNetPrice(); 

Print("Selected ESM7"); 

Print("Net Volume:", qty, 

"; Avg.Price:", price, 

"; Contract: ", oecAvgPositionContract(), 

", Account: ", oecAccount(), 

"; Gain: ", oecAvgPositionGain()); 

 

{ Cancel all working orders } 

for counter=0 to oecOrdersCount()-1 Begin 

oecSelectOrderByIndex(counter); 

if oecIsOrderIsFinalState() = false then 

begin 

if oecOrderType() = "Limit" then 

oecModify(oecOrderQuantity() * 2, "", 0, 0); 

if(oecCancelOrder()) then 

Print("Canceling order #", oecOrder()); 

end; 

end; 

end; 

 

{ Unfreeze OEC Trader and API and use local variables hereinafter } 

oecUnfreeze(); 

 

if oecIsCompleteConnected() then 

begin 

if qty > 0 then 

draft = "Sell" 

else 

draft = "Buy"; 

 

{ Create order draft. draft is a string variable with description of order } 

draft = oecCreateDraft(draft, 2 * AbsValue(qty), "Iceberg", (oecCurrentPriceLastPrice() + 

price)/2, 0, "None", "Reverse By TS"); 

 

{ Set Start time. End time stays default } 

draft = oecSetDraftTime(draft, ComputerDateTime() + 1, 0); 

 

{ Set Iceberg data. Volume = 1 } 

draft = oecSetDraftIceberg(draft, 1); 

Print(draft); 

 

{ Check draft data. oecCheckDraft should return empty string or invalid parts of order } 

Print("Invalid parts: ", oecCheckDraft(draft)); 

 

{ Send order } 

if(oecSendOrder(draft)) then 

Print("Sent successfully") 

else 

Print("Did not send"); 

 

{ Prepare other two drafts of OCO } 

draft = oecCreateDraft("Buy", 2, "Limit", oecCurrentPriceLastPrice() - 1, 0, "",""); 

draft2 = oecCreateDraft("Buy", 2, "Stop", oecCurrentPriceLastPrice() + 1, 0, "",""); 

 

 

 

{ And send OCO } 

if(oecSendOCO(draft, draft2)) then 

Print ("OCO is sent"); 
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draft3 = oecCreateDraft("Sell", 2, "Limit", oecCurrentPriceLastPrice() + 0.5, 0,"", 

"Main"); 

 

{ And bracket } 

if oecSendLinked2(draft3, draft, draft2) then 

Print ("Bracket is sent"); 

if AB <> "" then begin 

if ABSize > 0 then 

draft = "Sell" 

else begin 

draft = "Buy"; 

ABSize = - ABSize; 

end; 

draft = oecCreateDraft(draft, ABSize, "Market", 0, 0, "None", "Test of AB from TS"); 

 

{ Initialize Allocation Block structure before sending } 

oecInitializeAllocationBlock("TS AB", "LowAcctHighPrice", AB); 

if oecCheckDraft(draft) <> "" then 

Print("Invalid AB order: ", oecCheckDraft(draft)) 

else 

begin 

if oecSendOrder(draft) then 

Print("AB order is sent") 

else 

Print("AB order is not sent"); 

end; 

{ Reset the using of allocation block } 

oecInitializeAllocationBlock("", "", ""); 

end; 

end; 

else 

Print("OEC is not connected"); 

end; 

 

 

  



              AutoX Setup Guide 

Page 25                                 August 19, 2015  

Version 3.0 

Help 
There is a generated HTML file with short documentation on using the OEC API TradeStationTM function 
located at http://www.openecry.com/trading/software-highlights/index.cfm. 
 
Format of declaration: 

1. Original OEC API hierarchy 
2. Name of function without “oec” prefix 
3. Line for copy‐pasting to strategy code to import function 
4. Implemented .NET code in OEC API terms. 

 
Sample: 
 

Client.Accounts.SelectAccount 

SelectAccount 
External: "OecFuncs.dll", void, "oecSelectAccount", LPSTR{{Account}}; 

_Account = Client.Accounts[Account]; 

 

Client.Accounts.SelectAccountByID 

SelectAccountByID 
External: "OecFuncs.dll", void, "oecSelectAccountByID", int{{AccountID}}; 

_Account = Client.Accounts[AccountID]; 

Client.Accounts.SelectAccountByIndex 

SelectAccountByIndex 
External: "OecFuncs.dll", void, "oecSelectAccountByIndex", 

int{{AccountIndex}}; 

_Account = Client.Accounts.Values[AccountIndex]; 
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